Project

General

Profile

Bug #1221

Qt 5.15.12 broke the mouse scroll feature of the status icon plugin

Added by Artem S. Tashkinov 3 months ago. Updated 25 days ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
plugins/statusicon
Target version:
-
Start date:
January 28, 2024
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

I don't think any other updates could have done that but after Fedora 39 got this Qt 5 update I can no longer change the currently playing song or adjust the volume using the mouse scroll button.

Left, middle and right mouse clicking still work (show the main window, pause and show the context menu).

History

#1 Updated by Artem S. Tashkinov 3 months ago

I'm using a classic X11 session (XFCE without compositing). No wayland stuff.

#2 Updated by Artem S. Tashkinov 3 months ago

I've rebuilt audacious however the issue persists.

#3 Updated by Thomas Lange about 1 month ago

  • Status changed from New to Rejected
  • Category changed from libaudqt to plugins/statusicon

This is a known issue and is caused by Qt not implementing the scroll method for the StatusNotifierItem.

See also:
- https://github.com/orgs/audacious-media-player/discussions/121
- https://redmine.audacious-media-player.org/issues/960

Please continue with further comments in the GitHub discussion. Closing as rejected.

Also available in: Atom PDF